⚠ In case you've missed it we have migrated to our new website, with a brand new forum. For more details about the migration you can read our blog post for website migration. This forum is read-only and soon will be archived. ⚠

Cant edit or add new items

datamapper orm save error edit

  • Please log in to reply
3 replies to this topic

#1 Ezequiel



  • Members
  • Pip
  • 2 posts

Posted 10 September 2013 - 05:37 PM

Hello, i tried to use grocerycrud on my application with codeigniter and datamapper orm but i couldnt make it work..

Displaying information worked fine and removing items too. But when i tried to update or create new items i couldnt. 

The save and back  to the list button didnt do anything. And when i clicked the save button it just went back to the list but without saving anything.

I am wondering if the problem is because i use datamapper orm.. any help would be appreciated

#2 davidoster


    Grocery CRUD Ninja

  • Advanced Member
  • PipPipPip
  • 1,068 posts

Posted 11 September 2013 - 06:13 AM

Hello and welcome to the forums Ezequiel.

Well I have to admit that I don't have previous experience using the DataMapper ORM but from the looks of it, it gets your database objects and maps them to ORM objects, right?


Well, Grocery CRUD library it has each own logic and database engine that uses (the actual db model and some extra functions like set_relation), hence I find it extremely unlikely to be able to work with an ORM model on top unless it is designed to.

#3 Ezequiel



  • Members
  • Pip
  • 2 posts

Posted 11 September 2013 - 05:23 PM

Ok.. it's a shame because i really like groceryCrud. I will have to make the cruds manually.. thank you!

#4 tazoony



  • Members
  • Pip
  • 4 posts

Posted 24 November 2013 - 11:01 PM

Hi there !


I just wrote a topic about Datamapper conversion into Grocery_CRUD object ;-) 



Hope it will help you.

Enjoy !



Also tagged with one or more of these keywords: datamapper, orm, save, error, edit

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users